Commit e37396a3 authored by Pino Toscano's avatar Pino Toscano Committed by Philipp Erhardt
Browse files

qmake: disable pre-Qt5 methods, enable deprecation warnings

When build with Qt5, katarakt does not use pre-Qt5 compatibility
methods anymore, so do not enable them; OTOH, enable warnings for
deprecated methods.
parent 583aa30a
......@@ -7,7 +7,7 @@ QT += network xml dbus
greaterThan(QT_MAJOR_VERSION, 4) {
QT += widgets
DEFINES += QT_DISABLE_DEPRECATED_BEFORE=0
DEFINES += QT_DEPRECATED_WARNINGS
}
POPPLER = poppler-qt$$QT_MAJOR_VERSION
DEFINES += POPPLER_QT=$$QT_MAJOR_VERSION
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment